Ergebnis 1 bis 10 von 10

Thema: Webserver und OPCache

  1. #1

    Post Webserver und OPCache

    Hallo Forumianer,

    ich habe heute Nextcloud auf meiner AS6202T installiert.
    Leider gab bzw. gibt es ein paar Stolpersteine.
    Unter anderem würde ich dem Webserver gerne mitteilen, daß ich das Data-Verzeichnis nicht in /web liegen haben will.
    Dazu ist es nötig diesen Ordner in der PHP open_basedir anzugeben. Wo liegen die Configs für den Webserver?
    Zweites Problem: In welcher php.ini kann ich die Einstellungen für OPCache definieren?

    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	Unbenannt.PNG 
Hits:	32 
Größe:	28.2 KB 
ID:	238

    Vielen Dank für Eure Hilfe.

  2. #2
    *push*

    Hat hier im breiten Universum von Asustor noch keiner own,- Nextcloud auf seiner NAS installiert.
    Die Installation ist ja nebensächlich. Es geht primär um die Beseitigung der Einrichtungsmeldungen.

  3. #3
    Immer noch keiner?

  4. #4
    Senior Member
    Registriert seit
    Feb 2014
    Beiträge
    210
    Vielleicht musst du dich mit solch spezifischen fragen mal ans owncloud Forum wenden.

  5. #5
    Danke für Deine Antwort.
    Ich denke aber, daß es ein spezifisches Problem mit dem Apache von Asustor ist.
    Schwer zu glauben, daß ich der einzige hier im Forum bin, der seine Nextcloud selbst hosten will.
    Auf einer QNAP und Synology klappt das auch.
    Gibts eine Übersichtsseite von Asustor wo man die verwendeten Versionen, bzw. deren Konfiguration einsehen kann (insbesondere MariaBD und nginx/Apache)?

  6. #6
    Senior Member
    Registriert seit
    Feb 2014
    Beiträge
    210
    Also ich habe auch eine owncloud laufen. War eher um zu testen
    Nutze sie nicht so häufig. Hab mir mit den Anleitungen ausm Netz auch immer schwer getan.
    Ich bekomme auch eine Fehlermeldung nicht weg. Owncloud ist leider nicht besonders endanwenderfreundöich gestaltet

  7. #7
    Um welche Fehlermeldung handelt es sich bei Dir?

  8. #8
    Senior Member
    Registriert seit
    Feb 2014
    Beiträge
    210
    Ich solle auf https umstellen. Finde aber die erwähnte config Datei leider nicht. Die ganze Dokumentation der owncloud passt leider nicht aufs asustor

  9. #9
    Dann erstelle doch für die sub.domain.de unter welcher ownCloud erreichbar ist ein Zertifikat von LE.
    Alternativ das eingebaute Zert. nutzen. Da wird es aber vom Browser eine Meldung geben.

  10. #10
    Junior Member
    Registriert seit
    Apr 2017
    Beiträge
    8

    Lightbulb Nextcloud: Lösung für OPCache, PHP Memory Cache und Data Verzeichnis

    Zitat Zitat von rednag Beitrag anzeigen
    Hallo Forumianer,

    ich habe heute Nextcloud auf meiner AS6202T installiert.
    Leider gab bzw. gibt es ein paar Stolpersteine.
    Unter anderem würde ich dem Webserver gerne mitteilen, daß ich das Data-Verzeichnis nicht in /web liegen haben will.
    Dazu ist es nötig diesen Ordner in der PHP open_basedir anzugeben. Wo liegen die Configs für den Webserver?
    Zweites Problem: In welcher php.ini kann ich die Einstellungen für OPCache definieren?

    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	Unbenannt.PNG 
Hits:	32 
Größe:	28.2 KB 
ID:	238

    Vielen Dank für Eure Hilfe.
    Hallo rednag,

    Ich habe 2 Tage lang vor einem ähnlichen Problem gesessen. Da unser Asustor mit der PHP Version 5.6.30 arbeitet sind die Definitionen für den OPCache nicht in der php.ini einzutragen. Bei uns stehen die Einstellungen in der "opcache.ini", diese findest du hier:
    Code:
    /volume0/usr/builtin/etc/php5/conf.d/opcache.ini

    Um überhaupt so tief im System etwas bearbeiten zu können musst du vorher im Asustor Webinterface unter Services und Terminal den SSH Zugang inklusive SFTP aktivieren. Der ADM_Defender muss sofern genutzt den SSH- und SFTP-Service zulassen.
    Jetzt kannst du mit der Hilfe von PuTTY die opcache.ini bearbeiten. Ich bevorzuge aber eine grafische Oberfläche und nutze daher das Programm WinSCP.

    In der "opcache.ini" alles unterhalb der Zeile "zend_extension=opcache.so" durch die empfohlenen Einstellungen deiner Nextcloud ersetzen.
    Der fertige Inhalt sieht dann so aus:
    Code:
    [OPCACHE]
    zend_extension=opcache.so
    opcache.enable=1
    opcache.enable_cli=1
    opcache.interned_strings_buffer=8
    opcache.max_accelerated_files=10000
    opcache.memory_consumption=128
    opcache.save_comments=1
    opcache.revalidate_freq=1
    Danach einfach nur den Webserver neu starten und der OPCache sollte funktionieren.

    Die Einstellungen für den PHP Memory Cache kommen direkt in die "config.php" deines Nextcloud Ordners unter:
    Code:
    /volume1/Web/nextcloud12/config/config.php
    Dort wird die folgende Zeile:
    Code:
    'memcache.local' => '\OC\Memcache\APCu',
    zwischen den beiden Zeilen (die sollten ganz unten zu finden sein)
    Code:
    'dbpassword' => 'PZhgjfjZR8940jhhgOZ499djj32BJZF',
    'installed' => true,
    eingefügt. (die Zeichenfolge hinter 'dbpassword' => 'ist bei jedem anders')

    So sollte dass jetzt aussehen:
    Code:
    'dbpassword' => 'PZhgjfjZR8940jhhgOZ499djj32BJZF',
    'memcache.local' => '\OC\Memcache\APCu',
    'installed' => true,
    Ebenfalls in der "config.php" kann in der bereits bestehenden Zeile
    Code:
    'datadirectory' => '/volume1/Web/nextcloud12/data',
    der Pfad zum Data Verzeichnis nach eigenen Wünschen angepasst werden.

    Bei Zugriff übers Internet rate ich dringendst dazu den Server per HTTPS aufzurufen. Zertifikate gibt es kostenlos bei Lets-Encrypt, das kann wenn noch nicht geschehen im Zertifikatsmanager eingerichtet werden. HTTPS kann dann auch über den VirtualHost (leider nur manuell aber dafür sicher bei Updates der Nextcloud Software) oder über die .htaccess Datei (einfacher, muss aber nach jedem Update der Nextcloud Software erneut bearbeitet werden) erzwungen werden.

    MFG

    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	Nextcloud.jpg 
Hits:	6 
Größe:	52.4 KB 
ID:	275

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •