Ergebnis 1 bis 3 von 3

Thema: Raid 1 ohne Datenverlust wieder auflösen?

  1. #1

    Raid 1 ohne Datenverlust wieder auflösen?

    Hallo!

    Habe folgendes Problem:
    Ich hatte in meinem Asustor Nimbustor 2 eine super laute Toshiba NAS N300 4TB verbaut und diese einzeln betrieben. Jetzt wollte ich diese einfach durch eine neue leisere WD Red 4TB ersetzen. Nun habe ich geschaut, ob es irgendeine einmalige 1:1-Kopie-Funktion gibt, aber leider nichts gefunden. Ich hoffe ich habe nichts übersehen gehabt?! Nun dachte ich, na dann mach ich jetzt einfach temporär einen RAID 1 und löse ihn danach wieder auf. Pustekuchen! Nach 8 Stunden Synchronisierung musste ich leider feststellen, dass ein aufheben von RAID 1, um dann einfach wieder 2 einzelne Platten zu haben, ohne Datenverlust wohl gar nicht geht?!
    Wie komme ich denn nun wieder aus dieser Misere raus? Klar, alles neu machen, aber ich habe unter anderem im Plex-Server soviele Einstellungen vorgenommen bis er jetzt endlich einwandfrei läuft, dass ich das, abgesehen vom Arbeitsaufwand, eigentlich tunlichst vermeiden möchte.

    Hat jemand ne einfache Lösung???

    LG parnau

  2. #2
    So, da ich scheisse gebaut habe, hab ich nun alles ganz frisch wieder aufsetzen müssen. Problem ist also gelöst.

    Mein Resümee ist trotzdem:
    Wenn man ein RAID 1 erstellt hat, ist es fast unmöglich es wieder aufzuheben! Nach etwas suchen habe ich entdeckt, dass man in dem erstellten Volumen des RAID 1 eine Festplatte löschen kann. Da dachte ich, das könnte man ja mit der alten Platte machen und dann hat man nur noch eine, die man dann vielleicht als "Einzeln" wieder einbinden kann. Tja, das funktioniert leider nicht mehr. Die neue Platte wird dann als fehlerhaft angezeigt und man hat keinerlei Funktionen zur Verfügung, dies wieder zu ändern! Da ist dann wohl Ende Gelände.
    Habe die Platte dann mal versucht in einen Windows-Rechner reinzuhängen und mit einem Programm das Linux-EXT4-Formatierungen lesen kann, versucht die Daten zu retten. Leider konnte ich mit einer Fehlermeldung nicht darauf zugreifen. Ich habe dabei auch gesehen, dass durch den RAID 1-Verbund, mehrere Partitionen angelegt wurden. Das Ganze ist wohl doch etwas komplexer als ich dachte. Bin halt leider auch kein IT-Guru.
    Jetzt hab ich auch noch versucht, mit einem Daten-Rettungs-Programm was zu erreichen und das würde tatsächlich noch funktionieren. Man könnte sämtliche Daten wiederherstellen, allerdings wird einem alles ohne Ordnerstruktur und zum Teil mit eigens von dem Programm erstellten Datenamen präsentiert. Das war mir dann doch zu umständlich. Daher habe ich einige Daten lieber wieder von ihren Ursprungsorten bezogen und eben alles wieder neu aufegsetzt.
    Was will man machen...?!
    LG parnau

  3. #3
    Probiers doch mal einem bootfähigen lunix von nem usb stick...

    Ich habe auch schonmal probier die Daten unter Windows zu lesen und bin jedes mal daran gescheitert. Hab mir dann einen Ubuntu stick erstellt und damit gebootet. Damit konnte ich ext4 lesen.
    Das war allerdings ein myarchive also keine Platte eines Verbundes. Wie sich das ganze mit raid1 verhält kann ich leider nicht sagen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •