Probleme mit Plex Media Server

Laudano

Member
16 Dez. 2016
37
0
6
Hallo, Gemeinde,

ich habe auf meinem AS6102T die App "Plex Media Server" aus der App-Central installiert zwecks Film-Wiedergabe auf meinem Panasonic-TV über HDMI. Die entsprechenden Medien befinden sich auf dem NAS.

Nach dem Aufruf des PMS auf der NAS-Oberfläche erscheint die Plex-Startseite und der Möglichkeit, die eigenen Medien aufzurufen. Wenn ich dies tue, wird mir mitgeteilt, dass ich nun vor dem Zugriff auf meine Medien die "Plex Player Software" auf das Gerät mit den Medien-Dateien installieren müsse. Dafür wird eine Schaltfläche namens "Holen Sie sich den Plex Media Server". Ich bin davon ausgegangen, dass dieser bereits installiert sei. Kann jemand meine Verwirrung auflösen?

Jedenfalls werden dort verschiedene Plattformen unter ASUSTOR angeboten: Intel 32bit/64bit und 2xARM. Der AS6102T verfügt über eine Intel-Celeron-Plattform, so dass ich die 32bit-Version gewählt habe. Die heruntergeladenen 3 Dateien ( apkg-version, control.tar.gz und data.tar.gz) habe ich entpackt, kann sie aber nicht öffnen. Offenbar handelt es sich nur um Grafiken...

Und jetzt bin ich an dem Punkt angelangt, an dem ich nicht mehr weiterkomme. Für Hilfestellung wäre ich sehr dankbar.

Gruss von Laudano
 

Catamenia

Member
12 März 2017
286
2
18
Esslingen
Hallo lieber Laudano,

leider gibt es aktuell keine guten Apps, um über HDMI direkt Filme vom NAS zu gucken. Kodi gibt es ja schon länger nicht mehr...
Daher funktionieren aktuell nur die Streaming Lösungen, was aber nicht das schlechteste ist.

Plex oder Emby. Beides einfach zu konfigurieren und zu nutzen.

Du installierst auf dem ASUS Tor den Plex Media Server und/oder Emby. Dann kannst Du beides ausprobieren, was dir besser gefällt.
Die Mediaserver konfigurierst Du direkt auf dem NAS via Browser.

Danach installierst Du auf deinem Fernseher Plex und Emby als Apps.
Den Fernseher am besten auch direkt über LAN anbinden, wenn das geht und WLAN abschalten.

Die direkte HDMI Verbindung brauchst du dann erst mal nicht mehr, ausser du willst über das ASUS Portal über den Fernseher im Internet serven etc...

Im Forum gibt es auch einige Konfigurationsvorschläge für Plex etc...
Solltest Du noch weitere Hilfe benötigen, melde Dich ;)

Schönen Sonntag.
 

Laudano

Member
16 Dez. 2016
37
0
6
Hallo, Catamenia

zunächst danke für die Antwort. Die Installation des PMS habe ich über meinen PC auf der NAS-Oberfläche über die App Central vorgenommen. Offenbar ist dies nicht der richtige Weg, denn es erscheint jedes mal, wenn ich auf dem NAS vorhandene Medien dem PMS hinzufügen will, die Aufforderung, den PMS zu installieren. Und zwar auch dann, wenn ich vom TV per LAN aus auf den NAS zugreife. Irgend etwas muss ich übersehen haben...

Ich wünsche Dir trotz Corona eine schöne Woche
Gruß von Laudano
 

Catamenia

Member
12 März 2017
286
2
18
Esslingen
Hallo lieber Laudano,

Du solltest als aller erstes Deine Medien (Filme, Serien, Musik, Fotos etc..) prüfen, ob diese in einer sauberen Ordnerstruktur auf Deinem ASUSTOR NAS übersichtlich vorhanden sind, damit der Plex Media Server gut damit umgehen kann:

Plex 7.png

Danach prüfst Du bitte von Deinem PC über einen beliebigen Browser die Einstellungen Deines Plex Media Servers auf Deinem ASUSTOR NAS :)

Plex 1.png

Ich hab meine Plex Einstellungen hier für Dich zusammengesammelt, damit sollte dann auch bei Dir alles anschließend korrekt funktionieren.

Gehe Schritt für Schritt die Konfiguration Deines PMS über den PC über die ASUSTOR Oberfläche nach meinen Beispielen durch:

Hast Du ein Plex Konto korrekt angelegt?

Plex 2.png

Plex 3.jpg

Ist Dein Server aktuell erreichbar?

Plex 4.jpg

Stimmen Deine Plex Web Einstellungen?

Plex Web.jpg

Plex Web 2.jpg

Plex Web 3.jpg

Plex Web 4.jpg

Da ich immer nur max. 10 Bilder hochladen kann, geht es in der nächsten Antwort weiter...
 

Catamenia

Member
12 März 2017
286
2
18
Esslingen
Hallo lieber Laudano,

weiter geht es...

Netzwerkeinstellungen prüfen:

Netzwerk.jpg

Transcoder und Sprachen prüfen:

Transcoder.jpg

Sprachen.jpg

Die Agenten des Plex Media Servers in korrekter Reihenfolge und mit den korrekten Einstellungen versehen, bevor Medien dem Server hinzugefügt werden.
Die Reihenfolge der Agenten lässt sich über die drei Striche vor jedem Agenten beliebig ändern, in dem man auf die Striche klickt, gedrückt hält und dann die Position verändert!

Agenten 1.jpg

Agenten 2.jpg

Agenten 3.jpg

Agenten 4.png

Agenten 5.jpg

Agenten 6.png

Agenten 7.jpg

In dem nächsten Abschnitt kommen dann die Medien und wie man diese korrekt hinzufügt ;)
 

Catamenia

Member
12 März 2017
286
2
18
Esslingen
Hallo lieber Laudano,

nun der letzte Teil der Plex Einrichtung.

Korrekte Benennung der Medien vom Ordner bis zur Datei -> hatten wir ganz am Anfang schon, aber hier nochmal zur Erinnerung.
Am besten kopiert man sich den Titel des Films oder der Serie von der Seite https://www.themoviedb.org/ mit der Jahreszahl ;)

Plex 7.png

Eine Mediathek (Ordner mit Medien) einbinden

Plex 5.jpg

Plex 6.png

Plex 8.png

Plex 9.png

Plex 10.jpg

Wenn Du nun alles wie oben beschrieben eingerichtet hast und Du die Plex App auf Deinem Fernseher installiert hast (lösche diese sicherheitshalber nochmal und installier sie frisch, sicher ist sicher) sollte nun eigentlich alles funktionieren.

Über die App am Fernseher kannst Du den Server nicht konfigurieren, da es nur ein Client ist, der das spiegelt, was Du über den Plex Medien Server auf dem ASUSTOR wie oben eingestellt hast.

Wenn noch Fragen auftauchen, kannst Du diese hier gerne stellen :) Ich hoffe ich konnte Dir schon ein bisschen weiter helfen.
 

Laudano

Member
16 Dez. 2016
37
0
6
Hallo, Catamenia,

ganz lieben Dank für die Mühen, die Du Dir mit mir machst. Normalerweise habe ich trotz fortgeschrittenen Alters eigentliche keine Probleme mit Computer-Programmen, weil ja auch vieles gegoogelt werden kann. Dort klang die PMS-Installation auch sehr einfach...

Ich habe noch einmal ganz von vorn angefangen, mein Plex-Konto gelöscht und mich nach Installation der neuesten Version auf dem NAS mit einem neuen Konto angemeldet. Mein Startbildschirm (Vorgegebene Inhalte habe ich gelöscht) sieht allerdings etwas anders aus, als bei Dir:
Plex Startseite.jpg
Ein Klick auf "Mehr" brachte dies zum Vorschein:
Plex Startseite 2.jpg
und ein weiterer Klick auf "Deine Medien" ergab das Bild, das ich schon in meiner Eingangsfrage erwähnte:
Plex Medienauswahl.jpg

Unter "Einstellungen" kann ich lediglich mein Konto und den "Player" modifizieren, alles andere -wie aus Deinen Screenshots ersichtlich- ist für mich nicht zugänglich. Was mache ich falsch??

Z. Zt. habe ich auf dem NAS als Medien nur eigene Bluray-Videos im MP4-Format. Kann Plex das überhaupt verarbeiten? Danke nochmals schon jetzt für weitere Infos.

Ganz liebe Grüße aus Berlin von
Laudano
 

Catamenia

Member
12 März 2017
286
2
18
Esslingen
Hallo lieber Laudano,

sorry, dass ich mich jetzt erst wieder melde ;)

Bitte prüfe auf Deinem ASUSTOR NAS welche App Du installiert hast, siehe Screenshot ->

Plex 1.png

Wenn Du den Plex Media SERVER installiert hast, öffne bitte diesen auf Deinem Portal über den PC und gehe mal in die Einstellungen wie im nächsten Screenshot ->

Plex 2.jpg

Was siehst Du nun auf der linken Navigationsleiste?

Ganz lieben Gruß aus dem Raum Stuttgart ;)
 

Laudano

Member
16 Dez. 2016
37
0
6
Hallo, Catamenia

ich habe kein Problem damit, wenn Du Dich nicht sofort melden kannst. In diesen Zeiten gehören ganz andere Dinge dazu...

Also, installiert ist bei mir nur der PMS, nicht der Player:


Asustor Oberfläche.jpg


Nach dem Öffnen sieht die Startseite so aus (Habe sie in den Ausgangszustand versetzt):


Startseite 3.jpg


Und in den Einstellungen ist dies ersichtlich:


Plex Einstellungen.jpg


Und das sieht etwas anders aus, als bei Dir. Und das verstehe ich nicht...:confused:

Liebe Grüße aus Berlin
Laudano
 

Catamenia

Member
12 März 2017
286
2
18
Esslingen
Hallo lieber Laudano,

bitte deinstalliere den Plex Server bei Dir auf dem NAS über App Central, starte danach Dein NAS neu und installiere dann den Plex Media Server über App Central auf Deinem NAS über einen Browser neu.

Danach gehst Du wie in dieser Anleitung oder wie im Video beschrieben vor und danach kannst Du dann meine Anleitungen oben nutzen:

https://de.ccm.net/faq/12982-plex-media-server-installieren-und-konfigurieren

ein Installationsvideo:

https://www.youtube.com/watch?v=og25x0UHHpI

Meldest Dich wieder, wenn noch was unklar ist :)
 

Laudano

Member
16 Dez. 2016
37
0
6
Hallo, Catamenia,

ich bin ein wenig verwirrt hinsichtlich der Formulierung " installiere dann den Plex Media Server über App Central auf Deinem NAS über einen Browser neu".
Deshalb habe ich vor der Installation auf dem NAS versuchsweise die Installation auf meinem PC vorgenommen. Es wurde mir nur der Button "Installieren" angeboten, die Konfiguration erfolgte offenbar automatisch. Jedenfalls sah die Startseite genauso aus, wie ich sie Dir bereits übermittelt habe. Und ich war sofort angemeldet. Soll ich mein Konto löschen und es noch einmal versuchen?

Eine nochmalige Installation auf dem NAS brachte dasselbe Ergebnis. Ich bin absolut ratlos...:confused:

Liebe Grüße aus der Hauptstadt mir besten Wünschen für einen schönen Sonntag
Laudano
 

Catamenia

Member
12 März 2017
286
2
18
Esslingen
Hallo lieber Laudano,

versuch bitte mal Folgendes ohne Deinen Plexaccount zu löschen:

1. Plex App über App Central deinstallieren.
2. Danach im Dateiexplorer auf dem NAS den Ordner Plex löschen. Der liegt auf der obersten Ordnerebene.
3. NAS neustarten.
4. Plex Media Server über App Central wieder installieren, danach sollte die Konfiguration wieder möglich sein

Deinen Account brauchst du nie löschen, nur den Plex Ordner, da hier deine Einstellungen drin gespeichert werden.
Keine Angst, Plex legt diesen Ordner bei einer Neuinstallation wieder an.
 

Laudano

Member
16 Dez. 2016
37
0
6
Liebe Catamenia,

es hat geklappt. Du kannst jetzt Bescheid geben, dass man mich aus der Gummizelle holen kann...
Daaaaankeeeeee:eek:

Liebe Grüße
Laudano, Bärliner
 

Laudano

Member
16 Dez. 2016
37
0
6
Hallo, Catamenia,

ich muss leider noch einmal "stören". Die Wiedergabe meiner mp4-Videos über HDMI auf dem TV gerät extrem ins Stocken. Dem Plex-Forum habe ich entnommen, dass für ein flüssiges Abspielen à la VLC ein zusätzlicher Player (z. B. PMP) eingesetzt werden muss, da ansonsten Plex Web verwendet wird und dieser mit der Transcodierung überfordert ist. Das werde ich jetzt probieren. Und nochmals ein dickes Dankeschön:D

Gruß von Laudano

Nachtrag: Habe Plex Media Player auf NAS installiert, er taucht aber im Portal nicht auf. Hab' ich schon wieder die A...karte gezogen...?:rolleyes:

Noch'n Nachtrag: Asustor hat mir heute mitgeteilt, dass PMP nicht mehr supported wird. Und die Wiedergabeprobleme habe ich immer noch, obwohl DirectPlay eingeschaltet ist.
 

Catamenia

Member
12 März 2017
286
2
18
Esslingen
Hallo lieber Laudano,

bitte installiere auf deinem Fernseher über dein Smart TV, den Plex als App. Sollte dein Fernseher denke ich können,, ausser du hast kein Smart TV. Dann startest du die Plex App auf deinem Fernseher und meldest dich mit deinem Plex Account an. Dann solltest du alles abspielen können. Bei manchen Filmformaten hilft auch mal die Untertitel auszumachen oder ein anderes Tonformat auszuwählen.

Direkt über Hdmi vom Asustor auf den Fernseher geht bei mir aktuell auch nicht bzw. nicht richtig...

Das ging mal mit Kodi direkt, aber den gibt es ja offiziell nicht mehr für Asustor.
 

Laudano

Member
16 Dez. 2016
37
0
6
Hallo, Catamenia,

das hatte ich noch nicht erwähnt: Gerade bei Verwendung der Plex-App (PanasonicTV) tauchen die Probleme auf. Zu langsam kann mein Netzwerk (1GB an FritzBox 7590), Verbindung aller Geräte über LAN mittels 1GB-Netgear-Switch, eigentlich nicht sein. Selbst eine Verminderung der Video-Qualität auf 720p mit DirectPlay brachte keine Änderung. So langsam glaube ich an ein eine Hardware-Ursache. Vielleicht ist der NAS-Prozessor (Celeron 1,6GHz) zu schwach. Andererseits ist das Streamen über WLAN auf mein Handy absolut kein Problem, alles läuft flüssig, ebenso auf dem PC.

Das Ausgangsmaterial meiner Eigenvideos ist 4K, gerendert mit 1080p/50i. Vielleicht zuviel für den Asustor?

Grüße aus Berlin
Laudano
 

Catamenia

Member
12 März 2017
286
2
18
Esslingen
Hallo lieber Laudano,

eigentlich sollte das kein Problem sein.

Hast du mal probiert über DLNA direkt vom Fernseher auf das NAS zuzugreifen. DLNA muss im Plex aktiviert sein, siehe meine Einstellungen. Ansonsten solltest du deine Filme ggf. in MKVs umwandeln.
 

Roadrunner

Member
3 März 2016
52
0
6
Da grätsche ich mal kurz mit rein. Gibt's da ne Möglichkeit das das Asustor das umwandeln in MKV übernimmt?
 

Catamenia

Member
12 März 2017
286
2
18
Esslingen
Hallo lieber Roadrunner,

ich wüsste nicht, dass es so eine Möglichkeit gibt. Umwandeln muss man wohl schon noch mit diversen Tools.
 

Laudano

Member
16 Dez. 2016
37
0
6
Hallo, Catamenia,

danke für die Hinweise, ich werde sie in den nächsten Tagen ausprobieren und mich dann wieder melden.

Gruß Laudano